Page MenuHomeDevCentral

Pin PHP 7.4.23 for zenerre Jenkins CI agent
ClosedPublic

Authored by dereckson on Sat, May 7, 23:53.

Details

Summary

The Jenkins PHP agent image now uses PHP 8.1.5.

Some application like Auth Grove or tools. still run under PHP 7
in production. Probably best to keep an agent with PHP 7.4 to ease
the upgrade process to PHP 8.x

Ref T1677

Test Plan

salt-call --local state.sls roles/paas-docker/containers/jenkins_agent

Diff Detail

Repository
rOPS Nasqueron Operations
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

dereckson created this revision.

Replace image by image_flavour to avoid confuse paas_docker.get_image

This revision is now accepted and ready to land.Sun, May 8, 12:06