Page MenuHomeDevCentral

Don't install PhantomJS anymore on devserver role
Closed, ResolvedPublic

Description

PhantomJS isn't maintained anymore. It was an headless WebKit browser used for testing, generate screenshot of websites, etc.

Meanwhile, Firefox and Chromium both provides headless version.

According D1382 / b3ef1c3792, it was installed for a Foundation blank template, but this template doesn't require phantomjs anymore.


----------
          ID: devserver_software_dev_web
    Function: pkg.installed
      Result: False
     Comment: Problem encountered installing package(s). Additional info follows:

              errors:
                  - pkg: No packages available to install matching 'phantomjs' have been found in the repositories
     Started: 19:54:41.817974
    Duration: 1113.806 ms
     Changes:
...

Event Timeline

dereckson created this task.Jan 18 2020, 03:40
dereckson renamed this task from Don't install PhantomJS anymore to Don't install PhantomJS anymore on devserver role.Jan 18 2020, 03:49
dereckson claimed this task.
dereckson updated the task description. (Show Details)
dereckson updated the task description. (Show Details)
dereckson updated the task description. (Show Details)