Allow web publishing in public_html directories
Closed, DuplicatePublic

Description

References:

(Note nginx configuration has evolved a little in 8 years)

dereckson created this task.Jul 25 2016, 16:16
dereckson edited projects, added User-Dereckson; removed IRC.
dereckson moved this task from Backlog to Next on the User-Dereckson board.
dereckson claimed this task.Jul 25 2016, 19:38
dereckson added a comment.EditedJul 25 2016, 20:10

Oh yes references are outdated, this is now straightforward:

set userdir test_nginx_html;

location ~ ^/~(.+?)(/.*)?$ {
    alias /home/$1/$userdir$2;
    index index.html index.htm default.html default.htm;
    autoindex on;
}
dereckson moved this task from Next to In progress on the User-Dereckson board.Jul 25 2016, 20:20
dereckson closed this task as a duplicate of T819: Web hosting on Eglide.Jul 27 2016, 11:11
dereckson closed this task as a duplicate of T819: Web hosting on Eglide.
dereckson closed this task as a duplicate of T819: Web hosting on Eglide.